Thursday, September 20, 2012

The minority wins

Our latest poll about supporting multiple branches for both .NET3.5 and .NET4.0 closed a few days ago. The results were in favor of .NET4.0 by 60%. However this was not an election and and the voice of the 40% is clear and loud.

The new coming library we been working on has been refactored to .NET3.5 and in next version 12.1.7.2 we will remove the .NET4.0 dependency from the all other modules. However since our core libs now depend on .NET3.5 we see no reason for supporting 2 branches. We will return to our past branch which contained mixed .NET framework versions. Some modules like Workflow,Quartz, etc have a .NET4.0 dependency some not.

We will run a similar poll in the future to see the size of the minoritySmile. Thanks again everybody for your contribution!

Subscribe to XAF feed
Subscribe to community feed

DiggIt!